Docker에서 apt-get update가 실패할 때

ubuntu 14.04 를 기반으로 한 Dockerfile 에,SSH를 설치하기 위해 아래와 같이 작성했다고 하자.

그러면 archive.ubuntu.com Repository 에서 Update를 받는데, 갑자기 이런 메시지가 뜬다.

검색해 봐도 Docker나 Dockerfile의 문제 같지는 않다. 그렇다면 정말 Repository가 Hash Sum Mismatch 문제를 가지고 있는 것은 아닐까?

어차피 Build 하는 시점에는 어느 Repository를 써도 상관이 없으니, 전통의 kr.archive.ubuntu.com 를 사용하도록 Dockerfile을 수정해 봤다.

아주 잘 된다!